const regex = /(?<=[&\\?])password=[^&]*&?|&password=[^&]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[&\\\\?])password=[^&]*&?|&password=[^&]*', 'gm')
const str = `https://openapi.knx.org/v1/user/login?username=KNXpassword=0&passwords=250&63&password=n7psderwp¶m=test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}