import re
regex = re.compile(r"^\d{4}$", flags=re.MULTILINE)
test_str = ("2020\n"
"2019/10/16\n"
"2020/08/12 \n"
"31/01/2020 \n"
"2020-11-03 \n"
"05/01/2020 \n"
"04/17/2020 \n"
"2019/12/31 \n"
"2021-07-14\n"
"2019/12/04 \n"
"2010/12/16 \n"
"2021\n"
"04/03/2020 \n"
"4/30/2020\n"
"2011/07/18 \n"
"2017/06/20 \n"
"2019\n"
"2021-10-13 \n"
"2020\n"
"2021-07-14 \n"
"2021/11/08 \n"
"2021/1/8 \n"
"2020-11-03 \n"
"2021\n"
"2019/12/31\n"
"2019-12-04 \n"
"null\n"
"2020/01/04")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")