$re = '/.*?(\d{1,2}:\d{1,2}(?:\:\d{1,2}(?:\.\d{1,9})?)?).*/m';
$str = 'The time is 7:00.
The time is 7:00:05.
The time is 7:00:05.1.
The time is 7:00:05.123.
The time is 7:00:05.123456789.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);