package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/\w+\/(\d+)`)
var str = `/new_category/42`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}