$re = '/(?m)(^\d+)|(?<=\*).*$/m';
$str = '1 *Match
2 Line should not match, but 2 does
3 *Match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);