$re = '/http\:\/\/www\.mywebsite\.com\/id\/(\d+)\/page/';
$str = 'http://www.mywebsite.com/id/37246238/page';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);