re = /\/\*\*.*?\*\/\s*(?!function)/
str = '/**
 *
 *
 *
 *
*/function
/**
 *
 *
 *
 *
*/
'
# Print the match result
str.scan(re) do |match|
    puts match.to_s
end