$re = '/^(?=[\d-]{3,18}$)\d{1,6}-\d*[-]?\d+$/';
$str = '123123-1-1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);