#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<p>[\s]*(.*)"
Local $sString = "<div>" & @CRLF & _
" abc" & @CRLF & _
" efg" & @CRLF & _
" abc" & @CRLF & _
"</div>" & @CRLF & _
"<p>" & @CRLF & _
" abc" & @CRLF & _
" efg" & @CRLF & _
" abc" & @CRLF & _
" efg" & @CRLF & _
"</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")