$re = '/^[^DFIQUV]{2}\d{6}[A-D]$/';
$str = 'AA122123A';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);