// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r##"(?m)^(?:[^:\/?#]+:)?(?:(?:\/\/)?(?:[^\s\/?#]+\.)+[^\s\/?#]+(?:\/[^\s"#]*)?)$"##).unwrap();
let string = "xn--4gbrim.xn--wgbh1c
中文域名.中国
😄❤️🌟.ws
example.com
xn--mgbah1a3hjkrd.com
🍕🏞️🎵.online
技术论坛.中国
www.nck.gg
www.www2.test.com
xn--80aaag1a8aj.xn
商业网站.中国";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}