re = /^([a-z0-9_\-.]+)(?:\:([0-9]+))?(\/[^\?\s]*)?/m
str = 'website.host21.ru/contacts?p1=2&p2=3
website.host21.ru/contacts/
host1.host21.ru:80/contacts/
localhost:5372
baidu.c-_om
ekuiper_da
ekuiper_da:80/api
ekuiper:9081/a
ekuier:9081/api
localhost:9081
127.0.0.1:90/api
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end