package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\[MSG\]\n[\d ]+\n{2}\d{15}\n\d{4}mV\n\d{2}\n\d,\d,\d\n?\*{0,2}(\d{10})?\*{0,2}\n{2}\[READINGS\]\n(?m:([\d\s,]*))\[MSGEND\]$`)
var str = `[MSG]
4 031116 080423
543215432154321
3711mV
30
1,0,0
**1234567890**
[READINGS]
00451,00450,00402,06017
00000,021116 083000
00000
00000
00000
00000,031116 080000
[MSGEND]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}