import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Пример заголовка для статьи(\\s.+)";
final String string = "Пример заголовка для статьи 1 страница\n"
+ "Пример заголовка для статьи 45 страница\n"
+ "Пример заголовка для статьи 7 страница";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}