$re = '/^[a-zA-Z0-9\-]+$/';
$str = 'test-x';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);