re = /^(?=[a-z\d]*\/)(?=\/*[a-z\d])[a-z\d\/]+$/mi
str = 'A/C/D
A///D
//A///F
AADFFFG
//////'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end