$re = '/([a-z]+).*\|\s([0-9]+)/i';
$str = '[\'| Sofia | 300\']';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);