$re = '/[0-9]/';
$str = 'um2tres4cinco6sete8';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);