package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(/dc/i).+`)
var str = `/dc/i/aaaa
/dc/i`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}