$re = '/^.*?\n*?first.*?|\n*?second.*?\n*?$/m';
$str = 'fddfgdfgfdg phrase here first
sdafdsafdsa
sadfsadf
sadfdsaf
phrase here second
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);