package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[A-Za-z0-9._%+-]+@[A-Za-z0-9.-]+\.[A-Za-z]{2,4}\b`)
var str = `Blue Rhine - A Dubai based signage manufacturer Careers | Other Links | Contact Us » Who We Are What We Do Organization Chart Mission & Vision Our Strengths » Signage » Modular Facility Signage » MSS 0.5 Signet Infonorm Architectural Signage » Bosisio - Hotel Signs Retail Signage-Illuminated » 3d LED Maxx luxx Advertising light boxes » Profil Tension System Custom Made 3 D Metal Signs Flex face Signage Displays-Illuminated » Decolight –Crystal Light Box Magnetic Light Box Snap Frame Light Box Heavy Duty Snap Frame Notice Display light box Menu Panels Digital Signage » Application Segments » Dooh Hospitality Education Corporate Retail Understanding Digital Signage Digital Printing » Digital Printed Vinyl Erfurt - Wall Paper Cladding Jobs » Dibond Rhinebond Lighting Solutions » LEDCOM LED\'s » Blue View Samsung OK LED Slimlight Tridonic Statutory Signage » Safety Signs Traffic Signs Photoluminiscent Signs Our Specialised Services Maintenance/After Service » Automobiles Banking Electronics External Signs F & B Retails Fashion Retail Hospitality Schools Shopping Mall Products & Services Signage Modular Facility Signage MSS 0.5 Signet Infonorm Architectural Signage Bosisio - Hotel Signs Retail Signage-Illuminated 3d LED Maxx luxx Advertising light boxes Profil Tension System Custom Made 3 D Metal Signs Flex face Signage Displays-Illuminated Decolight –Crystal Light Box Magnetic Light Box Snap Frame Light Box Heavy Duty Snap Frame Notice Display light box Menu Panels Digital Signage Application Segments Dooh Hospitality Education Corporate Retail Understanding Digital Signage Digital Printing Digital Printed Vinyl Erfurt - Wall Paper Cladding Jobs Dibond Rhinebond Lighting Solutions LEDCOM LED's Blue View Samsung OK LED Slimlight Tridonic Statutory Signage Safety Signs Traffic Signs Photoluminiscent Signs Our Specialised Services Maintenance/After Service Brands Contact Us U.A.E Dubai inverstment park -Phase II P.O Box No: 114001 Dubai, United Arab Emirates Tel :00971 4 8857517 Fax :00971 4 8857507 Email: sales@brisigns.com Location Map INDIA Blue Rhine Sign and Advertising Materials India Pvt. Ltd. No.8/1, Near Tata Steel Yard, Dooravani Nagar Post, Vijinapura, Bangalore - 560 016 Tel : 0091-80-6546 458 Email: bluerhineindia@gmail.com Web: www.bluerhine.in Name * E-mail * ( will not be puiblished) Mobile * Enquiry Security code* Cannot read? Change text. Write down the word Copyright 2008 - 2017 Blue Rhine. All Rights Reserved. Designed by: ENH media`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}