import re
regex = re.compile(r"\$\s?(\d{1,3}(?:\.\d{3})+)(?:,\d+)?(?!\d)", flags=re.MULTILINE)
test_str = ("Debt 1 of 2 for an amount of: $ 58.610,00, Unpaid\n"
"Debt 1 of 2 for an amount of: $ 58.610.344,00, Unpaid\n"
"Debt 1 of 2 for an amount of: $ 58.610.523.344,00, Unpaid")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")