#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(<(?:(?:(?:(script|style|object|embed|applet|noframes|noscript|noembed)(?:\s+(?=((?:"[\S\s]*?"|'[\S\s]*?'|(?:(?!\/>)[^>])?)+))\3)?\s*>)[\S\s]*?<\/\2\s*(?=>))|(?:\/?[\w:]+\s*\/?)|(?:[\w:]+\s+(?:"[\S\s]*?"|'[\S\s]*?'|[^>]?)+\s*\/?)|\?[\S\s]*?\?|(?:!(?:(?:DOCTYPE[\S\s]*?)|(?:\[CDATA\[[\S\s]*?\]\])|(?:--[\S\s]*?--)|(?:ATTLIST[\S\s]*?)|(?:ENTITY[\S\s]*?)|(?:ELEMENT[\S\s]*?))))>)|([^<>]*?)(querry)"
Local $sString = "<body class="mediawiki querry ltr sitedir-ltr ns-0 ns-subject page-International_English_Language_Testing_System skin-vector action-view vector-animateLayout">" & @CRLF & _
" <div id="mw-page-base" class="noprint"></div>" & @CRLF & _
" <div id="mw-head-base" class="noprint"></div>" & @CRLF & _
" <div id="content" class="mw-body" role="main">" & @CRLF & _
" <a id="top"></a>" & @CRLF & _
"" & @CRLF & _
"and also a normal querry" & @CRLF & _
"" & @CRLF & _
" <div id="siteNotice"><!-- CentralNotice --></div>" & @CRLF & _
" <h1 id="firstHeading" class="firstHeading" lang="en"><span dir="auto">International English Language Testing System</span></h1>" & @CRLF & _
" <div id="bodyContent" class="mw-body-content">" & @CRLF & _
" <div id="siteSub">From Wikipedia, the free encyclopedia</div>" & @CRLF & _
" <div id="contentSub"> (Redirected from <a href="/w/index.php?title=IELTS&redirect=no" title="IELTS">IELTS</a>)</div>" & @CRLF & _
" <div id="jump-to-nav" class="mw-jump">" & @CRLF & _
" Jump to: <a href="#mw-navigation">navigation</a>, <a href="#p-search">search</a>" & @CRLF & _
" </div>" & @CRLF & _
" <div id="mw-content-text" lang="en" dir="ltr" class="mw-content-ltr"><table class="infobox vevent" cellspacing="3" style="border-spacing:3px;width:22em;">" & @CRLF & _
"<caption class="summary">International English Language Testing System</caption>" & @CRLF & _
"<tr>" & @CRLF & _
"<td colspan="2" style="text-align:center;"><a href="/wiki/File:IELTS_logo.svg" class="image"><img alt="IELTS logo.svg" src="//upload.wikimedia.org/wikipedia/commons/thumb/7/7f/IELTS_logo.svg/300px-IELTS_logo.svg.png" width="300" height="113" srcset="//upload.wikimedia.org/wikipedia/commons/thumb/7/7f/IELTS_logo.svg/450px-IELTS_logo.svg.png 1.5x, //upload.wikimedia.org/wikipedia/commons/thumb/7/7f/IELTS_logo.svg/600px-IELTS_logo.svg.png 2x" data-file-width="778" data-file-height="293" /></a></td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<th scope="row" style="text-align:left;">Acronym</th>" & @CRLF & _
"<td>IELTS</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<th scope="row" style="text-align:left;">Type</th>" & @CRLF & _
"<td>Standardized test. Available in 2 versions: "Academic" and "General training".</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<th scope="row" style="text-align:left;">Developer / administrator</th>" & @CRLF & _
"<td><a href="/wiki/Cambridge_English_Language_Assessment" title="Cambridge English Language Assessment">Cambridge English Language Assessment</a>, <a href="/wiki/British_Council" title="British Council">British Council</a>, <a href="/wiki/IDP_Education" title="IDP Education">IDP Education</a>.</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<th scope="row" style="text-align:left;">Knowledge/skill(s) tested</th>" & @CRLF & _
"<td>Listening, reading, writing and speaking of the <a href="/wiki/English_language" title="English language">English language</a>.</td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<th scope="row" style="text-align:left;">Purpose</th>" & @CRLF & _
"<td>To assess the English language proficiency of non-native English speakers.</td>" & @CRLF & _
"</tr>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")