$re = '/^(?=.*(?:^|\s)(?:[iİ]ç|Anadolu)(?!\S)).*/i';
$str = 'The text is İç Anadolu here.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);