re = /^[^\/](?:.)+[^\/]$/m
str = '/apply/
apply
//apply//
/////apply
asdf
radda
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end