$re = '/(?<=\=\s).+/';
$str = 'Field1 = 123@abc.com
Field2 = abc- det - FLP
Field3 = VCN:20161115:74055:5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);