# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"GA_ClientID__c\";[^\"]*\"([^\"]*)\""
test_str = ("99524\";s:9:\"FirstName\";s:2:\"John\";s:8:\"LastName\";s:8:\"Doe\";s:7:\"Company\";s:10:\"Sample\";s:5:\"Email\";s:20:\"xxxxx@gmail.com\";s:5:\"Phone\";s:10:\"8888888888\";s:7:\"Country\";s:13:\"United States\";s:5:\"Title\";s:8:\"Creative\";s:5:\"State\";s:2:\"NC\";s:13:\"Last_Asset__c\";s:40:\"White Paper: Be a More Strategic Partner\";s:16:\"Last_Campaign__c\";s:18:\"70160000000q6TgAAI\";s:16:\"Referring_URL__c\";s:8:\"[direct]\";s:19:\"leadPriorityMarketo\";s:2:\"P2\";s:18:\"ProductInterest__c\";s:9:\"sample\";s:14:\"landingpageurl\";s:359:\"https://www.sample.com;mkt_tok=samplesamplesamplesample\";s:14:\"GA_ClientID__c\";s:38:\"75714ae471df63202106404675dasd800097erer1849995367\";s:13:\"Drupal_SID__c\";s:36:\"e1380c07-0258-47de-aaf8-82d4d8061e1a\";s:4:\"form\";s:4:\"1046\";} ```\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.