package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w\-]\.\w{1,3}$`)
var str = `1.exe
a.c
-.zip
1
1a.exe`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}