$re = '/^[a-zA-Z\d\-]\.[a-zA-Z]{1,3}$/m';
$str = '1.exe
a.c
-.zip
1
1a.exe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);