package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)a[bc]`)
var str = `a
ab
ac
abc
acb
ad
ae`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}