import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\$?[0-9]{1,3}(?:,[0-9]{3})*(?:\\.[0-9]+)?$";
final String string = "Here are some test cases that it needs to match\n\n"
+ "76,249.25\n"
+ "131,588.00\n"
+ "7.09\n"
+ "21.27\n"
+ "420.42\n"
+ "54.77\n"
+ "32.848\n"
+ "3,056.12\n"
+ "0.009\n"
+ "0.01\n"
+ "32.85\n"
+ "2,948.59\n"
+ "$99,249.25\n"
+ "$9.0000\n"
+ "$1,800.0000\n"
+ "$1,000,000\n"
+ "Here are some test cases that it should not target\n\n"
+ "666-257-6443\n"
+ "F1A 5G9\n"
+ "Bolt, Locating, M8 x 1.25 x 30 L\n"
+ "Precision Washer, 304 SS, 0.63 OD x 0.31\n"
+ "Flat Washer 300 Series SS; Pack of 50\n"
+ "U-SSFAN 0.63-L6.00-F0.75-B0.64-T0.38-SC5.62\n"
+ "U-CLBUM 0.63-D0.88-L0.875\n"
+ "U-WSSS 0.38-D0.88-T0.125\n"
+ "U-BGHK 6002ZZ - H1.50\n"
+ "U-SSCS 0.38-B0.38\n"
+ "6412K42\n"
+ "Std Dowel, 3/8\" x 1-1/2\" Lg, Steel\n"
+ "2019.07.05\n"
+ "2092-002.0180\n"
+ "SHCMG 0.25-L1.00\n"
+ "280160717";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}