package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\s*((\d|[1-9]\d+)(\s+(\d|[1-9]\d+)){2}(\s+((0x(\d|[a-f]|[A-F}]){1,8})|[1-9]\d+|\d))*)\s*(,\s*(\d|[1-9]\d+)(\s+(\d|[1-9]\d+)){2}(\s+((0x(\d|[a-f]|[A-F}]){1,8})|[1-9]\d+|\d))*)*\s*$`)
var str = `1 1 1 1, 1 1 1 2, 1 01 1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}