$re = '/testcase\.(?!testObjInstance)\S+/m';
$str = 'testcase.abcd testcase.testObjInstance';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);