package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(main|development|master|(features|tests|(bug|hot)fix)(\/[a-zA-Z0-9]+([-_][a-zA-Z0-9]+)*){1,2}|release\/[0-9]+(\.[0-9]+)*(-(alpha|beta|rc)[0-9]*)?)$`)
var str = `development
main
bugfix/user-list
bugfix/user_list
bugfix/123
bugfix/123/account-update
bugfix/123/account_update
bugfix/User_crud/account-update
bugfix/User_crud/account_update
tests/api
tests/123
tests/123/hello
release/1.0.1
release/1.0.1-beta1
release/1.0.1-beta
release/1.0.1-rc3
it should not match following
bugfix/
bugfix/-
bugfix/_
bugfix/-name
bugfix/_name
bugfix/-/name
bugfix/-/-
bugfix/-/_
release/v1.0.1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}