re = /^\s*(([+-]?((0|[1-9][0-9]*)(\.[0-9]*)?|\.[0-9]+)([Ee][+-]?[0-9]+)?)\s*,?\s*)*$/m
str = ' -3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end