import re
regex = re.compile(r"^[A-Z]\d{2}\.?\d{0,2}$", flags=re.MULTILINE)
test_str = ("D99\n"
"M00.0\n"
"M01.6\n"
"J98.3\n"
"T05.0\n"
"M96.81\n"
"D68.20\n\n"
"9D.0\n"
"6G\n"
"7H.\n"
"M96.811\n"
"J234.82\n"
"G687.1\n"
"GU87.11")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")