re = /<\?(?!php|=|xml)?\D*?>/
str = '<?php endif ?>
<? endif ?>
<?= $test?>dasd
asdasdwda546awd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end