package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(0[1-9]|[1-9][0-9])0{6}|(0[1-9]|[1-9][0-9]){2}0{4}|((?:0[1-9]|[1-9][0-9])){3}00|(?:0[1-9]|[1-9][0-9]){4})$`)
var str = `00000000
01000000
10000000
10440044
99990000
99999900
99000099
77007788
55555555`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}