$re = '/^(?!.*bab.*bab).*$/m';
$str = 'bab
aaa
aba
aaaabab
bbbbabbbbb
bbbababaaabab
babbab
babab
baaaa
abbaaaaabbaba
babbab
babab
baababaabaaab
babbbaaabab
aabbbabbabbabaaa
a
c
bbb
baabbabaabab
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);