$re = '/[^0-9.]/m';
$str = 'abc 1.0
foo 3.14 bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);