$re = '/Clock advanced by [[:digit:]]* ticks/m';
$str = 'Jun 3 10:04:32 bigip.midomain.local notice tmm1[17621]: 01010029:5: Clock advanced by 316 ticks';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);