#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!\d)20\d{6}\D?\d{6}(?!\d)"
Local $sString = "a20171217091011 = None instead of 2017-12-17 09:10:11" & @CRLF & _
"b20171217091011 = None instead of 2017-12-17 09:10:11" & @CRLF & _
" 20171217091011 = None instead of 2017-12-17 09:10:11" & @CRLF & _
"-20171217091011 = None instead of 2017-12-17 09:10:11" & @CRLF & _
"_20171217091011 = None instead of 2017-12-17 09:10:11" & @CRLF & _
"aa20171217091011 = None instead of 2017-12-17 09:10:11" & @CRLF & _
"a1-20171217091011 = None instead of 2017-12-17 09:10:11" & @CRLF & _
"123_20171217091011 = None instead of 2017-12-17 09:10:11" & @CRLF & _
"123 20171217091011 = None instead of 2017-12-17 09:10:11" & @CRLF & _
"123=20171217091011 = None instead of 2017-12-17 09:10:11" & @CRLF & _
"201712170910110 = 2017-12-17 09:10:11 instead of None" & @CRLF & _
"a20171217091011a = None instead of 2017-12-17 09:10:11" & @CRLF & _
"(20171217091011) = None instead of 2017-12-17 09:10:11" & @CRLF & _
"a-20171217091011 b = None instead of 2017-12-17 09:10:11" & @CRLF & _
"123(20171217091011)456 = None instead of 2017-12-17 09:10:11" & @CRLF & _
" 20171217091011 = None instead of 2017-12-17 09:10:11" & @CRLF & _
"2017 20171217091011 2017 = None instead of 2017-12-17 09:10:11" & @CRLF & _
"20171218-20171217091011-070809 = 2017-12-18 20:17:12 instead of 2017-12-17 09:10:11" & @CRLF & _
"123(20171217-091011)456 = None instead of 2017-12-17 09:10:11" & @CRLF & _
"a2017(20171217 091011)b = None instead of 2017-12-17 09:10:11" & @CRLF & _
"2017xx(20171217?091011)cc2017 = None instead of 2017-12-17 09:10:11" & @CRLF & _
"A-20171116-080910-20171217091011 = None instead of 2017-11-16 08:09:10"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")