#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\[SF_KAFKA_CONNECTOR\] (?<message>.*) \((?<code_reference>[^ ]*)\)$"
Local $sString = "[SF_KAFKA_CONNECTOR] deleted sink/account_entitlements_staging/0/22446382_22446393_1585089396398.json.gz from stage SNOWFLAKE_KAFKA_CONNECTOR_sink_STAGE_account_entitlements_staging (com.snowflake.kafka.connector.internal.SnowflakeConnectionServiceV1:95)" & @CRLF & _
"[SF_KAFKA_CONNECTOR] purge 2 files from stage: SNOWFLAKE_KAFKA_CONNECTOR_sink_STAGE_account_entitlements_staging (com.snowflake.kafka.connector.internal.SnowflakeConnectionServiceV1:79)" & @CRLF & _
"[SF_KAFKA_CONNECTOR] generated file name: sink/account_entitlements_staging/0/22446400_22446402_1585089458654.json.gz (com.snowflake.kafka.connector.internal.FileNameUtils:45)" & @CRLF & _
"[SF_KAFKA_CONNECTOR] flush buffer: 3 records, 35866 bytes, offset 22446400 - 22446402 (com.snowflake.kafka.connector.internal.SnowflakeSinkServiceV1:95)" & @CRLF & _
"[SF_KAFKA_CONNECTOR] put file sink/account_entitlements_staging/0/22446400_22446402_1585089458654.json.gz to stage SNOWFLAKE_KAFKA_CONNECTOR_sink_STAGE_account_entitlements_staging (com.snowflake.kafka.connector.internal.SnowflakeConnectionServiceV1:95)" & @CRLF & _
"[SF_KAFKA_CONNECTOR] ingest file: sink/account_entitlements_staging/0/22446400_22446402_1585089458654.json.gz (com.snowflake.kafka.connector.internal.SnowflakeIngestionServiceV1:95)" & @CRLF & _
"[SF_KAFKA_CONNECTOR] pipe SNOWFLAKE_KAFKA_CONNECTOR_sink_PIPE_account_entitlements_staging_0, flush pipe: sink/account_entitlements_staging/0/22446400_22446402_1585089458654.json.gz (com.snowflake.kafka.connector.internal.SnowflakeSinkServiceV1:79)" & @CRLF & _
"[SF_KAFKA_CONNECTOR] pipe SNOWFLAKE_KAFKA_CONNECTOR_sink_PIPE_account_entitlements_staging_0: flusher flushed (com.snowflake.kafka.connector.internal.SnowflakeSinkServiceV1:95)" & @CRLF & _
"[SF_KAFKA_CONNECTOR] generated file name: sink/account_entitlements_staging/0/22446403_22446411_1585089489491.json.gz (com.snowflake.kafka.connector.internal.FileNameUtils:45)" & @CRLF & _
"[SF_KAFKA_CONNECTOR] flush buffer: 9 records, 94748 bytes, offset 22446403 - 22446411 (com.snowflake.kafka.connector.internal.SnowflakeSinkServiceV1:95)" & @CRLF & _
"[SF_KAFKA_CONNECTOR] put file sink/account_entitlements_staging/0/22446403_22446411_1585089489491.json.gz to stage [2020-03-25 02:19:06,168] INFO [Consumer clientId=connector-consumer-sink-0, groupId=connect-sink] Cluster ID: l8tlDKPoQn25uMmLW2-taw (org.apache.kafka.clients.Metadata:266)" & @CRLF & _
"[2020-03-25 02:19:06,170] INFO [Consumer clientId=connector-consumer-sink-0, groupId=connect-sink] Discovered group coordinator chi-staging-kafka-872s9z2.nr-ops.net:9092 (id: 2147483541 rack: null) (org.apache.kafka.clients.consumer.internals.AbstractCoordinator:728)" & @CRLF & _
"[2020-03-25 02:19:06,173] INFO [Consumer clientId=connector-consumer-sink-0, groupId=connect-sink] Revoking previously assigned partitions [] (org.apache.kafka.clients.consumer.internals.ConsumerCoordinator:476)" & @CRLF & _
"[2020-03-25 02:19:06,176] INFO [Consumer clientId=connector-consumer-sink-0, groupId=connect-sink] (Re-)joining group (org.apache.kafka.clients.consumer.internals.AbstractCoordinator:505)" & @CRLF & _
"[2020-03-25 02:19:07,291] INFO [Consumer clientId=connector-consumer-sink-0, groupId=connect-sink] Successfully joined group with generation 105 (org.apache.kafka.clients.consumer.internals.AbstractCoordinator:469)" & @CRLF & _
"[2020-03-25 02:19:07,297] INFO [Consumer clientId=connector-consumer-sink-0, groupId=connect-sink] Setting newly assigned partitions: account_entitlements-0 (org.apache.kafka.clients.consumer.internals.ConsumerCoordinator:283)" & @CRLF & _
"[2020-03-25 02:19:07,379] INFO [Consumer clientId=connector-consumer-sink-0, groupId=connect-sink] Setting offset for partition account_entitlements-0 to the committed offset FetchPosition{offset=22447142, offsetEpoch=Optional.empty, currentLeader=LeaderAndEpoch{leader=chi-staging-kafka-jv8xnx2.nr-ops.net:9092 (id: 4 rack: ord1), epoch=-1}} (org.apache.kafka.clients.consumer.internals.ConsumerCoordinator:525)" & @CRLF & _
"[2020-03-25 02:19:07,381] INFO" & @CRLF & _
"[SF_KAFKA_CONNECTOR] SnowflakeSinkTask[ID:0]:open, TopicPartitions: [account_entitlements-0] (com.snowflake.kafka.connector.SnowflakeSinkTask:170)" & @CRLF & _
"[2020-03-25 02:19:08,058] INFO" & @CRLF & _
"[SF_KAFKA_CONNECTOR] initialized the pipe connector for pipe RAW.KAFKA.SNOWFLAKE_KAFKA_CONNECTOR_sink_PIPE_account_entitlements_staging_0 (com.snowflake.kafka.connector.internal.SnowflakeIngestionServiceV1:79)" & @CRLF & _
"[2020-03-25 02:19:08,060] INFO" & @CRLF & _
"[SF_KAFKA_CONNECTOR] pipe: SNOWFLAKE_KAFKA_CONNECTOR_sink_PIPE_account_entitlements_staging_0 - service started (com.snowflake.kafka.connector.internal.SnowflakeSinkServiceV1:79)" & @CRLF & _
"[2020-03-25 02:19:08,962] INFO" & @CRLF & _
"[SF_KAFKA_CONNECTOR] SnowflakeSinkTask[ID:0]:put 209 records (com.snowflake.kafka.connector.SnowflakeSinkTask:205)" & @CRLF & _
"[2020-03-25 02:19:08,964] INFO" & @CRLF & _
"[SF_KAFKA_CONNECTOR] init pipe: SNOWFLAKE_KAFKA_CONNECTOR_sink_PIPE_account_entitlements_staging_0 (com.snowflake.kafka.connector.internal.SnowflakeSinkServiceV1:79)" & @CRLF & _
"[2020-03-25 02:19:09,552] INFO" & @CRLF & _
"[SF_KAFKA_CONNECTOR] Using existing table account_entitlements_staging. (com.snowflake.kafka.connector.internal.SnowflakeSinkServiceV1:79)" & @CRLF & _
"[2020-03-25 02:19:10,094] INFO" & @CRLF & _
"[SF_KAFKA_CONNECTOR] list stage SNOWFLAKE_KAFKA_CONNECTOR_sink_STAGE_account_entitlements_staging retrieved 1 file names (com.snowflake.kafka.connector.internal.SnowflakeConnectionServiceV1:79)" & @CRLF & _
"[2020-03-25 02:19:10,094] INFO" & @CRLF & _
"[SF_KAFKA_CONNECTOR] Using existing stage SNOWFLAKE_KAFKA_CONNECTOR_sink_STAGE_account_entitlements_staging. (com.snowflake.kafka.connector.internal.SnowflakeSinkServiceV1:79)" & @CRLF & _
"[2020-03-25 02:19:10,786] INFO" & @CRLF & _
"[SF_KAFKA_CONNECTOR] list stage SNOWFLAKE_KAFKA_CONNECTOR_sink_STAGE_account_entitlements_staging retrieved 1 file names (com.snowflake.kafka.connector.internal.SnowflakeConnectionServiceV1:79)" & @CRLF & _
"[2020-03-25 02:19:11,551] INFO" & @CRLF & _
"[SF_KAFKA_CONNECTOR] read load history between 2020-03-25T02:10:14Z and 2020-03-25T02:19:10Z. retrieved 0 records. (com.snowflake.kafka.connector.internal.SnowflakeIngestionServiceV1:79)" & @CRLF & _
"[2020-03-25 02:19:11,909] INFO" & @CRLF & _
"[SF_KAFKA_CONNECTOR] pipe SNOWFLAKE_KAFKA_CONNECTOR_sink_PIPE_account_entitlements_staging_0 : Recovered 1 files (com.snowflake.kafka.connector.internal.SnowflakeSinkServiceV1:79)" & @CRLF & _
"[2020-03-25 02:19:11,910] INFO" & @CRLF & _
"[SF_KAFKA_CONNECTOR] pipe SNOWFLAKE_KAFKA_CONNECTOR_sink_PIPE_account_entitlements_staging_0, recovered from existing pipe (com.snowflake.kafka.connector.internal.SnowflakeSinkServiceV1:79)" & @CRLF & _
"[2020-03-25 02:19:11,912] INFO" & @CRLF & _
"[SF_KAFKA_CONNECTOR] pipe SNOWFLAKE_KAFKA_CONNECTOR_sink_PIPE_account_entitlements_staging_0: cleaner started (com.snowflake.kafka.connector.internal.SnowflakeSinkServiceV1:79)" & @CRLF & _
"[2020-03-25 02:19:11,914] INFO" & @CRLF & _
"[SF_KAFKA_CONNECTOR] pipe SNOWFLAKE_KAFKA_CONNECTOR_sink_PIPE_account_entitlements_staging_0: flusher started (com.snowflake.kafka.connector.internal.SnowflakeSinkServiceV1:79)" & @CRLF & _
"[2020-03-25 02:19:11,918] INFO" & @CRLF & _
"[SF_KAFKA_CONNECTOR] SnowflakeSinkTask[ID:0]:put 9 records (com.snowflake.kafka.connector.SnowflakeSinkTask:205)" & @CRLF & _
"[2020-03-25 02:19:12,211] INFO" & @CRLF & _
"[SF_KAFKA_CONNECTOR] SnowflakeSinkTask[ID:0]:put 0 records (com.snowflake.kafka.connector.SnowflakeSinkTask:205)" & @CRLF & _
"[2020-03-25 02:19:12,212] INFO WorkerSinkTask{id=sink-0} Committing offsets asynchronously using sequence number 1: {account_entitlements-0=OffsetAndMetadata{offset=22447143, leaderEpoch=null, metadata=''}} (org.apache.kafka.connect.runtime.WorkerSinkTask:345)" & @CRLF & _
"[2020-03-25 02:19:22,221] INFO" & @CRLF & _
"[SF_KAFKA_CONNECTOR] SnowflakeSinkTask[ID:0]:put 0 records (com.snowflake.kafka.connector.SnowflakeSinkTask:205)" & @CRLF & _
"[2020-03-25 02:19:32,223] INFO" & @CRLF & _
"[SF_KAFKA_CONNECTOR] SnowflakeSinkTask[ID:0]:put 0 records (com.snowflake.kafka.connector.SnowflakeSinkTask:205)" & @CRLF & _
"[2020-03-25 02:19:42,224] INFO" & @CRLF & _
"[SF_KAFKA_CONNECTOR] SnowflakeSinkTask[ID:0]:put 0 records (com.snowflake.kafka.connector.SnowflakeSinkTask:205)" & @CRLF & _
"[2020-03-25 02:19:44,386] INFO" & @CRLF & _
"[SF_KAFKA_CONNECTOR] pipe SNOWFLAKE_KAFKA_CONNECTOR_sink_PIPE_account_entitlements_staging_0, flush pipe: sink/account_entitlements_staging/0/22447346_22447359_1585102781881.json.gz (com.snowflake.kafka.connector.internal.SnowflakeSinkServiceV1:79)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")