# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^.*7.*son.*$)|(^.*son.*7.*$)"
test_str = ("son\n"
"7\n"
"147\n"
"743\n"
"174\n"
"............7\n"
"7..............\n"
"-----------\n"
".........\n"
".\n"
"8\n\n"
"sona\n"
"ason\n"
"soan\n"
"on\n"
"sonnnnnnnnnnnnnnnnn\n"
"sssssssssssssson\n\n"
"7son\n"
"son7\n"
"son...7\n"
"7...son\n\n"
"***7son\n"
"***son7\n"
"***son...7\n"
"***7...son\n\n"
"7son***\n"
"son7***\n"
"son...7***\n"
"7...son***")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.