#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!.*/(add-)?reviews?/$)listing/(.+?)/([^\/.]+)/?(reviews/?(.+?)?/?)?/?$"
Local $sString = "listing/united-states/postname/" & @CRLF & _
"listing/united-states/california/postname/" & @CRLF & _
"listing/united-states/california/chino/postname/" & @CRLF & _
"listing/united-states/california/chino/postname/reviews/testreview/" & @CRLF & _
"" & @CRLF & _
"listing/united-states/california/chino/postname1/reviews/" & @CRLF & _
"" & @CRLF & _
"listing/united-states/california/chino/postname2/add-review/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")