import Foundation
let pattern = #"://www\.google\.com/test\b(?!-)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"A beautiful sentence http://www.google.com/test, You can reach here http://www.google.com/test-mi or http://www.google.com/test/aliveli"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"://test.google.com"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)