import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:(?:(?:\\s{0,1})(?:\\d{2})){3})(?:\\.\\w{1,18}){0,1})(.*)";
final String string = "00 24 13.13 Scopes of Bids (Multiple Contracts) \n"
+ "00 24 13.16 Scopes of Bids (Multiple-Prime Contract) \n"
+ "00 00 00.123456789abc Procurement and Contracting Requirements \n"
+ "00 01 01 Project Title Page \n"
+ "00 01 05 Certifications Page \n"
+ "00 01 07 Seals Page \n"
+ "00 01 10 Table of Contents \n"
+ "00 01 15 List of Drawing Sheets \n"
+ "00 01 20 List of Schedules \n"
+ "00 10 00 Solicitation \n"
+ "00 11 00 Advertisements and Invitations \n"
+ "00 11 13 Advertisement for Bids \n"
+ "00 11 16 Invitation to Bid \n"
+ "00 11 19 Request for Proposal \n"
+ "00 11 53 Request for Qualifications \n"
+ "00 20 00 Instructions for Procurement \n"
+ "00 21 00 Instructions \n"
+ "00 21 13 Instructions to Bidders \n"
+ "00 21 16 Instructions to Proposers \n"
+ "00 22 00 Supplementary Instructions \n"
+ "00 22 13 Supplementary Instructions to Bidders \n"
+ "00 22 16 Supplementary Instructions to Proposers \n"
+ "00 23 00 Procurement Definitions \n"
+ "00 24 00 Procurement Scopes \n"
+ "00 24 13 Scopes of Bids ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}