re = /(\w+) \1/m
str = '匹配相同的连续出现的单词
the little cat is in the hat hat, we like it.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end