const regex = /^(8058|5899|5898|6010|6018|6014|6063)[0-9]{10,15}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(8058|5899|5898|6010|6018|6014|6063)[0-9]{10,15}', 'g')
const str = `8058996888285610
58996888285610`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}