// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/(\d{1,})\/").unwrap();
let string = "https://mangadex.org/title/40103/yuusha-no-gawari-ni-maou-toubatsu-shitara-tegara-wo-yokodoroi-saremashita
https://mangadex.org/title/8487/yuusha-ni-narenakatta-ore-wa-shibushibu-shuushoku-o-ketsuishimashita
https://mangadex.org/title/661/toaru-kagaku-no-railgun";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}